BSV Forum - Support - How and where?

WYSIWYG: source and spacing

Jul 26 2012 09:03 am   #1asphodel
Since about 2 weeks ago, when I use the WYSIWYG editor in Source mode and <p></p> for paragraph breaks instead of <br><br>, the site has been adding an extra <br> between the <p></p> tags. For example, if the Source was <p>paragraph text</p>, the final output became <p><br>paragraph text</p>. The odd thing is that the Preview looks perfectly fine, but the final output displays extra line breaks. It doesn't matter if the html contains extra carriage returns in between paragraphs or not. Just wondering if this is an intended effect? I much prefer using WYSIWYG in Source mode, but it's a bit hard when the Preview and the final output don't match...
Jul 26 2012 11:45 pm   #2slaymesoftly
Since about 2 weeks ago, when I use the WYSIWYG editor in Source mode and

 

for paragraph breaks instead of

, the site has been adding an extra
between the

 

tags. For example, if the Source was

paragraph text

, the final output became


paragraph text

. The odd thing is that the Preview looks perfectly fine, but the final output displays extra line breaks. It doesn't matter if the html contains extra carriage returns in between paragraphs or not. Just wondering if this is an intended effect? I much prefer using WYSIWYG in Source mode, but it's a bit hard when the Preview and the final output don't match...


I hope Dia sees this, or Always_jbj. They may be able to answer your question.  I find that if I use the "paste from Word" link (above) I don't need to put any html in my chapters, they go up just as they are, breaks and all.  I have had issues with finding extra paragraph spaces, but not now that I'm using "Paste from Word".  However, WYSIWYG editor in Source mode means abosolutely nothing to me, so it could be you have another issue entirely.
I am not a minion of Evil...
I am upper management.
Jul 27 2012 07:12 am   #3asphodel
I like having my computer do exactly what I tell it to do, so I tend to get along better with html than Word. (The auto-bulleting gets me every time, grr.) But I'll work around the extra line breaks if I have to.
Jul 27 2012 05:19 pm   #4slaymesoftly
I like having my computer do exactly what I tell it to do, so I tend to get along better with html than Word. (The auto-bulleting gets me every time, grr.) But I'll work around the extra line breaks if I have to.

I like having my computer do exactly what I tell it to do
I hear that!  I think it's the same thing I ran into though - whether you insert the html or Word does, the text box on the site wants to add the space. Oddly enough, I found I can't use Word's autoformat for paragraphs without losing my spacing entirely (on all sites, not just here), so now I have that turned off and I manually skip a line when I want to have a new paragraph.
I am not a minion of Evil...
I am upper management.
Jul 27 2012 11:57 pm   #5Always_jbj
Since about 2 weeks ago, when I use the WYSIWYG editor in Source mode and

 

for paragraph breaks instead of

, the site has been adding an extra
between the

 

tags. For example, if the Source was

paragraph text

, the final output became


paragraph text

. The odd thing is that the Preview looks perfectly fine, but the final output displays extra line breaks. It doesn't matter if the html contains extra carriage returns in between paragraphs or not. Just wondering if this is an intended effect? I much prefer using WYSIWYG in Source mode, but it's a bit hard when the Preview and the final output don't match...

I hope Dia sees this, or Always_jbj. They may be able to answer your question.  I find that if I use the "paste from Word" link (above) I don't need to put any html in my chapters, they go up just as they are, breaks and all.  I have had issues with finding extra paragraph spaces, but not now that I'm using "Paste from Word".  However, WYSIWYG editor in Source mode means abosolutely nothing to me, so it could be you have another issue entirely.



LOL Why me? I know nothing about code! I use the HTML cleaner thingy, but I'm not sure if it still works...it's been far too long since I've had something to post.
Aim from the heart
Some will love and some will curse you, baby
You can go to war
But only if you have to 


Fanfic ~*~ Artwork ~*~ Live Journal
Jul 28 2012 01:03 am   #6slaymesoftly
Since about 2 weeks ago, when I use the WYSIWYG editor in Source mode and

 

for paragraph breaks instead of

, the site has been adding an extra
between the

 

tags. For example, if the Source was

paragraph text

, the final output became


paragraph text

. The odd thing is that the Preview looks perfectly fine, but the final output displays extra line breaks. It doesn't matter if the html contains extra carriage returns in between paragraphs or not. Just wondering if this is an intended effect? I much prefer using WYSIWYG in Source mode, but it's a bit hard when the Preview and the final output don't match...

I hope Dia sees this, or Always_jbj. They may be able to answer your question.  I find that if I use the "paste from Word" link (above) I don't need to put any html in my chapters, they go up just as they are, breaks and all.  I have had issues with finding extra paragraph spaces, but not now that I'm using "Paste from Word".  However, WYSIWYG editor in Source mode means abosolutely nothing to me, so it could be you have another issue entirely.



LOL Why me? I know nothing about code! I use the HTML cleaner thingy, but I'm not sure if it still works...it's been far too long since I've had something to post.


LOL - because you know about software stuff that isn't the basic stuff I know. I had no idea what she was talking about, so thought maybe it was something like your Semagic or something. But you knew it was code, see? So you did know more than I did.
I am not a minion of Evil...
I am upper management.